[links-list] Re: problems with links-2.0pre3

Martin Pergel mper7437 at artax.karlin.mff.cuni.cz
Fri May 24 13:05:12 PDT 2002


Hallo,

On Fri, 24 May 2002, Cheryl Homiak wrote:

> I am trying to use links-2.0pre3 with ssl and with javascript enabled.
> First of
> all, I got this message at the end of the "make".
>
> session.o: In function `get_temp_name':
> /usr/local/src/links-2.0pre3/session.c:556: the use of `tempnam' is dangerous, b
> etter use `mkstemp'
>
> But it didn't give me an error so I installed for now. Fine.
> Only when I started it up, I found that i'm getting urls frequently in English
> plus something mixed in in another language (maybe czech?). Very
> confusing, since it's all on the same screen.
> Here's a little sample.
>
> Podtekl zasobnik otcu!
>
> Vjizdim do fce assig[ Allow ]ji...
> What is going on here and what can I do about it. I do have "English" chosen in
> the setup.
> I am using woody debian linux.
> Also, if it's a problem with the pre3 rather than something I need to do, where
> do I find a pre2 or pre1. I didn't see either of these on the home page; a
> search brought up the cataloging in freshmeat but I haven't found the actual
> file.

     this problem has nothing common with your distribution. Somehow it
turned up that in 2.0pre3 javascript debugging is turned on. If you are
confused or upset by it, please turn it off with this patch:

------------------------------------------------------------------------
diff -r -u links-blbe/builtin.c links-2.0pre3/builtin.c
--- links-blbe/builtin.c	Fri May 24 21:44:12 2002
+++ links-2.0pre3/builtin.c	Fri May 24 21:44:58 2002
@@ -114,8 +114,8 @@
 			js_mem_free(b);

 #define idebug(a) printf(a);
-//#undef idebug
-//#define idebug(a)
+#undef idebug
+#define idebug(a)

 long MIN1KEY;

diff -r -u links-blbe/ipret.c links-2.0pre3/ipret.c
--- links-blbe/ipret.c	Fri May 24 21:44:13 2002
+++ links-2.0pre3/ipret.c	Fri May 24 21:44:52 2002
@@ -66,8 +66,8 @@
 /* #define JS_DEBUG_2 1 */
 #define debug(a) \
 	printf(a)
-//#undef debug
-//#define debug(a)
+#undef debug
+#define debug(a)
 #define KROKU 100

 extern lns fotr_je_lotr;

-----------------------------------------------------------------

     I'm sorry for this bug, but the version 2.0pre3 had to be taken from
CVS in (as I remember) in a very short time in which I commited files
which had debugging on, this state held for 5 minutes just after I ran
links and found that it shows debug messages, then I turned it off.

     I've rewritten macros which have made these problems, if this
problem turns up sometimes in future, it will be enough to redirect
stderr to /dev/null (2>/dev/null).

     Have a nice day
								PerM


-- 
Unsubscribe: send email to links-list-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the links-list mailing list